Jan 19, 2017
Mehul Harry (DevExpress)

Angular 2 now officially supported with DevExtreme v16.2.4

The DevExtreme v16.2.4 release is now available and with it comes the official support for the Angular 2 framework.

Angular

This means that you can use:

  • Angular CLI and Webpack that help you to bootstrap a new project and quickly add the powerful DevExtreme widgets
  • Other package managers like SystemJS and Rollup
  • DevExtreme Validation - All built-in DevExtreme validation features are now available inside the DevExtreme Angular 2 components
  • New Configuration Components - we've introduced two types of configuration components. The first type provides a convenient and efficient way for binding ‘deep’ properties. The second type allows you to declare collection property items (e.g. DataGrid columns, TabPanel tabs, etc.) via markup

Webinar - To learn more about Angular and DevExtreme, please register for my upcoming webinar: Getting started with Angular 2 and DevExtreme Widgets

New Angular Demo

To help you visualize the powerful ways in which you can use DevExtreme and Angular, we've created a version of our 'Golf Club' demo.

Try the demo online here: https://devexpress.github.io/golfclub/

Download the source from GitHub: https://github.com/DevExpress/golfclub

What's new

Major issues fixed:

Known issues:

Try Angular 2 and DevExtreme

To get started using the versatile DevExtreme widgets with Angular 2, please take a look at the GitHub project page.

Then, drop me a line below with your thoughts, thanks.