All docs
V20.1
20.1
19.2
The page you are viewing does not exist in version 19.2. This link will take you to the root page.
19.1
The page you are viewing does not exist in version 19.1. This link will take you to the root page.
18.2
The page you are viewing does not exist in version 18.2. This link will take you to the root page.
18.1
The page you are viewing does not exist in version 18.1. This link will take you to the root page.
17.2
The page you are viewing does not exist in version 17.2. This link will take you to the root page.
17.1
The page you are viewing does not exist in version 17.1. This link will take you to the root page.
16.2
The page you are viewing does not exist in version 16.2. This link will take you to the root page.

npm

npm is used to deliver DevExtreme to Angular, Vue, and React applications. The following packages are provided:

Install the latest stable version:

npm install devextreme@20.1 --save --save-exact

npm install devextreme-angular@20.1 --save --save-exact // to use DevExtreme with Angular
npm install devextreme-vue@20.1 --save --save-exact // to use DevExtreme with Vue
npm install devextreme-react@20.1 --save --save-exact  // to use DevExtreme with React

Install the latest published version. It can be stable or pre-release. Pre-release versions contain hotfixes and new features for early testing.

npm install devextreme@20.1-next --save --save-exact

npm install devextreme-angular@20.1-next --save --save-exact // to use DevExtreme with Angular
npm install devextreme-vue@20.1-next --save --save-exact // to use DevExtreme with Vue
npm install devextreme-react@20.1-next --save --save-exact  // to use DevExtreme with React
NOTE
We recommend saving an exact version of DevExtreme to avoid unexpected updates because DevExtreme does not use Semantic Versioning. In our versioning system, the first and middle numbers indicate a major release which may contain behavior changes.
See Also