Overview

NOTE
At the time of version 16.1, DevExtreme ASP.NET MVC Wrappers were in the Community Technology Preview (CTP) status. This product saw its full release in version 17.1.

This topic shows how to download and install DevExtreme ASP.NET MVC Wrappers and then run a sample ASP.NET MVC application.

Environment and Requirements

DevExtreme ASP.NET MVC Wrappers support:

  • .NET Framework 4.0 and later / .NET Core 1.0.1
  • ASP.NET MVC 3 and later
  • Visual Studio 2012 and later
NOTE
If you use Visual Studio 2012, make sure that you have the following updates and hotfixes applied. This ensures proper Razor code highlighting and the absence of unexpected dialog boxes.
- Visual Studio 2012 Update 5
- ASP.NET and Web Tools 2013.1 for Visual Studio 2012
- KB3002339 hotfix

Apart from the libraries required by DevExtreme itself, DevExtreme ASP.NET MVC Wrappers have the following dependencies.

Download

You can download the DevExtreme installer (.exe file) here.

Installation

Run the DevExtreme installer. The setup wizard will guide you through the installation steps.

Location

If you did not change the default installation path in the setup wizard, all DevExtreme components, including ASP.NET MVC Wrappers, are located in C:\Program Files (x86)\DevExpress <version>\DevExtreme.

ASP.NET MVC 3, 4 and 5 binaries are installed into System\Bin\AspNet.
ASP.NET Core (MVC 6) package is installed into System\Bin\AspNetCore.

See Also

Sample Application

DevExtreme ASP.NET MVC Wrappers come with a sample application that shows how to configure almost every widget from the DevExtreme library. This application is built using ASP.NET MVC 5 and Visual Studio 2012. You can find it in C:\Users\Public\Documents\DevExpress Demos <version>\DevExtreme\ASP.NET Wrappers (CTP)\MVC5\WidgetGallery.sln.

See Also