Yarn

You can use Yarn to install the following DevExtreme npm packages:

Install the latest stable version:

yarn add devextreme@20.1 --exact

yarn add devextreme-angular@20.1 --exact // to use DevExtreme with Angular
yarn add devextreme-vue@20.1 --exact // to use DevExtreme with Vue
yarn add devextreme-react@20.1 --exact  // to use DevExtreme with React

Install the latest published version. It can be stable or pre-release. Pre-release versions contain hotfixes and new features for early testing.

yarn add devextreme@20.1-next --exact

yarn add devextreme-angular@20.1-next --exact // to use DevExtreme with Angular
yarn add devextreme-vue@20.1-next --exact // to use DevExtreme with Vue
yarn add devextreme-react@20.1-next --exact  // to use DevExtreme with React
NOTE
We recommend saving an exact version of DevExtreme to avoid unexpected updates because DevExtreme does not use Semantic Versioning. In our versioning system, the first and middle numbers indicate a major release which may contain behavior changes.
See Also