DevExtreme Dependencies

DevExtreme has the following dependencies.

  • jQuery versions 2.1 - 2.2 and 3.x

Optionally, you can use DevExtreme with the following MVVM frameworks.

  • Knockout versions 2.2.3 - 2.3.0 and 3.1.0 - 3.4.0
  • AngularJS versions 1.2 - 1.5
  • Angular versions 2.2.1+
    For information on installing and using DevExtreme with Angular, see the devextreme-angular repository on GitHub.

Some functionality relies on additional libraries.

See Also